infostabil > edb.* > edb.regneark

Erik Isager (13.05.2010, 21:16)
Hej

Hvor er det jeg retter i excel 2007, så uge nr er rigtig.

i følge kalender starter uge 1 4 januar, men excel mener det er uge 2.

mvh Erik
Harald Staff (13.05.2010, 22:32)
"Rigtig" handler om hvilken standard, der er flere:
[..]
[..]

HTH. Beste hilsen Harald

"Erik Isager" <erikisager> wrote in message
news:6298
[..]
Is (13.05.2010, 22:54)
Den 13-05-2010 22:32, Harald Staff skrev:
> "Rigtig" handler om hvilken standard, der er flere:
> [..]
> [..]
>> HTH. Beste hilsen Harald
>> "Erik Isager" <erikisager> wrote in message

> news:6298 tak for svar


"rigtig" ja der er vel en årsag til at excel regner som den gør. men nu
mente jeg også i forhold til den papkalender jeg også har :-)

Er der et sted man kan se hvilke år der er problemer med i forhold til
uge nr ????

mvh Erik
Harald Staff (13.05.2010, 23:41)
"Is" <erikisager> wrote in message
news:6298
> Den 13-05-2010 22:32, Harald Staff skrev:
> tak for svar
> "rigtig" ja der er vel en årsag til at excel regner som den gør. men nu
> mente jeg også i forhold til den papkalender jeg også har :-)
> Er der et sted man kan se hvilke år der er problemer med i forhold til uge
> nr ????
> mvh Erik


Der er et problem de år 1. januar er på en fredag, lørdag eller søndag.
Stedet er din til enhver tid gjeldende papkalender.

!!!!

Beste hilsen Harald
Jan Kronsell (14.05.2010, 10:01)
Is wrote:
> Den 13-05-2010 22:32, Harald Staff skrev:
> tak for svar
> "rigtig" ja der er vel en årsag til at excel regner som den gør. men
> nu mente jeg også i forhold til den papkalender jeg også har :-)
> Er der et sted man kan se hvilke år der er problemer med i forhold til
> uge nr ????
> mvh Erik


Uge 1 i Excel (som er amerikansk standard) er altid den uge, der indeholder
den første januar. Hos os er uge 1 altid den uge, der indeholder den første
torsdag.

Jan
KS (14.05.2010, 10:43)
"Jan Kronsell" <kronsell(nomorespam)> skrev i meddelelsen
news:db0f
> Is wrote:
> Uge 1 i Excel (som er amerikansk standard) er altid den uge, der
> indeholder den første januar. Hos os er uge 1 altid den uge, der
> indeholder den første torsdag.

I de tidligere versioner kunne man rette det, ved at sætte den til at regne
efter 1904-systemet, og
så stadigvæk "uge 1 altid den uge, der indeholder den første torsdag" - om
et virker i 2007 ved jeg ikke, men prøv.

Mvh KS
Is (14.05.2010, 21:57)
Den 14-05-2010 10:43, KS skrev:
> "Jan Kronsell" <kronsell(nomorespam)> skrev i meddelelsen
> news:db0f
> I de tidligere versioner kunne man rette det, ved at sætte den til at
> regne efter 1904-systemet, og
> så stadigvæk "uge 1 altid den uge, der indeholder den første torsdag" -
> om et virker i 2007 ved jeg ikke, men prøv.
> Mvh KS


jeg valgte nok ikke den bedste løsning, men den virker lige nu og her:

=HVIS(ER.TOM(A5);"";HVIS(ÅR(A5)=2010;UGE.NR(A5;1)-1;UGE.NR(A5;1)))
inspireret af noget jeg googlede mig frem til

tak for svar

mvh ERik
Jan Kronsell (14.05.2010, 22:37)
> jeg valgte nok ikke den bedste løsning, men den virker lige nu og her:
> =HVIS(ER.TOM(A5);"";HVIS(ÅR(A5)=2010;UGE.NR(A5;1)-1;UGE.NR(A5;1)))
> inspireret af noget jeg googlede mig frem til
> tak for svar Denne burde virke generelt


=HVIS(UGEDAG(DATO(ÅR(A1);1;1);2)>4;UGE.NR(A1)-1;UGE.NR(A1))

men kræver at tilføjelsesprogrammet Analysis Toolpak er installeret.

Jan
Is (14.05.2010, 22:58)
Den 14-05-2010 22:37, Jan Kronsell skrev:
> Denne burde virke generelt
> =HVIS(UGEDAG(DATO(ÅR(A1);1;1);2)>4;UGE.NR(A1)-1;UGE.NR(A1))
> men kræver at tilføjelsesprogrammet Analysis Toolpak er installeret.
> Jan
>Tak


den prøver jeg

mvh Erik Isager
Jan Kronsell (14.05.2010, 23:54)
Is wrote:
> Den 14-05-2010 22:37, Jan Kronsell skrev:
> Tak
> den prøver jeg
> mvh Erik Isager


Ok :-)

Jan
Lignende emner